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ΠΡΟΕΙΔΟΠΟΙΗΣΗ 

Όταν χρησιμοποιείτε αυτό το προϊόν, λάβετε υπόψη τα ακόλουθα 

προειδοποιητικά σημεία: 

1. Αυτό το προϊόν περιέχει πολλά μικρά μέρη. Η 

κατάποση ή η ακατάλληλη λειτουργία μπορεί να 

προκαλέσει σοβαρές λοιμώξεις και θάνατο. Ζητήστε 

άμεση ιατρική βοήθεια όταν συμβεί το ατύχημα. 

2. Απαγορεύστε αυστηρά τη χρήση αυτού του προϊόντος 

και των εξαρτημάτων του κοντά σε πρίζα AC ή άλλα 

κυκλώματα σε περίπτωση πιθανού κινδύνου 

ηλεκτροπληξίας. 

3. Απαγορεύστε αυστηρά τη χρήση αυτού του προϊόντος 

κοντά σε οποιοδήποτε υγρό ή φωτιά. 

4. Κρατήστε τα αγώγιμα υλικά μακριά από αυτό το 

προϊόν. 

5. Μην επιτρέπετε σε παιδιά κάτω των 3 ετών να 

χρησιμοποιούν αυτό το προϊόν χωρίς την επίβλεψη 

ενηλίκου. Τοποθετήστε αυτό το προϊόν σε θέση όπου 

δεν μπορούν να φτάσουν τα παιδιά κάτω των 3 ετών. 

6. Μην αποθηκεύετε ή χρησιμοποιείτε αυτό το προϊόν σε 

ακραία περιβάλλοντα όπως υπερβολική ζέστη ή κρύο, 

υψηλή υγρασία, κάτω από το άμεσο ηλιακό φως κ.λπ. 

7. Θυμηθείτε να σπάσετε το κύκλωμα όταν δεν 

χρειάζεται. 

8. Ορισμένα μέρη αυτού του προϊόντος μπορεί να 

ζεσταθούν όταν χρησιμοποιούνται σε συγκεκριμένα 

σχέδια κυκλωμάτων, κάτι που είναι φυσιολογικό. 

9. Η ακατάλληλη χρήση μπορεί να προκαλέσει 

υπερθέρμανση. 

10. Η χρήση εξαρτημάτων που δεν συμμορφώνονται με 

τις προδιαγραφές μπορεί να προκαλέσει ζημιά στο 

προϊόν. 
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Εισαγωγή 

Το SCRAPY KIT είναι κατασκευασμένο με βάση τη χρήση του 

μικροελεγκτή Raspberry Pi Pico. Το «SCRAPY KIT» 

δημιουργείται στο πλαίσιο ενός συγχρηματοδοτούμενου έργου 

Erasmus+. 

Η νέα τάση στην εξ αποστάσεως εκπαίδευση, που έφερε η 

πανδημία του COVID-19, δημιουργεί ένα κενό στη διδασκαλία 

και την εξάσκηση δραστηριοτήτων με τη σωματική πληροφορική 

που φτάνει σε μαθητές που διατρέχουν κίνδυνο χαμηλής 

απόδοσης σε τέτοια θέματα STEM. 

Στόχος του KIT είναι να υποστηρίξει και να προωθήσει την 

πρακτική εκπαιδευτική μάθηση στους φυσικούς υπολογιστές και 

στον προγραμματισμό, σε περιπτώσεις εξ αποστάσεως 

διδασκαλίας και εντός της τάξης. Το KIT παρέχει έναν 

συνδυασμό αρχών φυσικών υπολογιστών και προγραμματισμού 

με υλικό και λογισμικό, οδηγώντας σε μια καινοτόμο εμπειρία 

εκμάθησης. 

Το πεδίο εφαρμογής αυτού του Εγχειριδίου είναι να: 

- Σας ενημερώσει για τα εξαρτήματα του κιτ και τη χρήση 

των κύριων ηλεκτρονικών στοιχείων. 

- Σας καθοδηγεί βήμα προς βήμα για να 

συναρμολογήσετε αποτελεσματικά το KIT, λαμβάνοντας 

υπόψη τις σχετικές προφυλάξεις. 

- Σας παράσχει πειράματα για τη χρήση των εξαρτημάτων 

και τη σύνδεση με τον μικροελεγκτή Pico. 

- Σας παράσχει πειράματα με τις λειτουργίες και το πεδίο 

εφαρμογής κάθε ηλεκτρονικού στοιχείου. 

Απολαύστε την ανάγνωση και διασκεδάστε μέσω 

πρακτικής εξάσκησης και πειραματισμού με το 

SCRAPY KIT 
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Περιλαμβάνoνται στο SCRAPY KIT 

  

  

 

 

 

GPIO Breakout Board 
Raspberry Pi Pico (2pcs) 

 

 

Μονάδα τροφοδοσίας 
MB-102 (1 τεμ.) 

 

Λευκό breadboard 830 
τμχ (1 τμχ) + 400 τμχ (1 

τεμ.)  

 

Κουμπί (1 τεμ.) & 
Καπάκι κουμπιού (1 

τεμ.)  

 

Buzzer (1pc) 
 

 

Αντιστάσεις 220 Ohm (5 
τμχ) + 1k Ohm (5 τμχ)  

 

 
 
 

Φωτοαντίσταση LDR (1 
τεμ.)  

 

 

100uF capacitor (1pc)  
 

 

LED 3 χιλιοστά Μπλε (1 
τμχ), Πράσινο (1 τμχ), 

Κόκκινο (1 τεμ.) Κίτρινο 
(1 τεμ.)  

 

RGB LED 5mm (1pc) 

 

 

Σερβοκινητήρας SG90 (1 
τεμ.)  

 

 
 
 

OLED I2C ICC (1pc) 
 

 

Αισθητήρας υπερήχων 
HC-SR04 (1 τεμ.) 

 

Αισθητήρας ανιχνευτή 
κίνησης PIR HC-SR501 

(1 τεμ.)  

 

Ψηφιακός αισθητήρας 
θερμοκρασίας και 

υγρασίας DHT11 (1 τεμ.)
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Αισθητήρας σταγόνας 
βροχής (1 τμχ) 

 

Περιστροφικό 
ποτενσιόμετρο Γραμμικό 

B1k Ohm (1 τεμ.)  

Αισθητήρας κραδασμών 
SW-420 (1 τεμ.) 

 
 

 

Αισθητήρας φλόγας (1 
τμχ)  

 

 
 

Αισθητήρας ανίχνευσης 
ήχου υψηλής 

ευαισθησίας (1 τεμ.)

 
 

Υγρόμετρο εδάφους / 
Αισθητήρας ανίχνευσης 

υγρασίας (1 τεμ.) 

 

Μονάδα αισθητήρα 
υπέρυθρων υπερύθρων 

KY-032 (1 τεμ.)

 
 

Μονάδα Joystick (1 τεμ.) 

 

Καλώδιο USB σε micro-
USB 1m (1 τεμ.) 

 
 
 

6 x μπαταρίες AA 1,5V (1 
τμχ) + θήκη (1 τεμ.)

 

Καλώδια Jumper (6 τεμ.)  

 

Πλαστικές βίδες (10 τμχ), 
πλαστικά παξιμάδια (6 

τμχ), πλαστικές κολόνες 
(10 τμχ) 
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Επεξήγηση εξαρτημάτων 

1. Τι είναι το breadboard (Πλακέτα 
Διασύνδεσης); 

 

Το breadboard είναι μια πλαστική πλακέτα με μικροσκοπικές 

οπές που επιτρέπουν την εύκολη εισαγωγή ηλεκτρονικών 

εξαρτημάτων (τρανζίστορ, αντιστάσεις, τσιπ, κ.λπ.) για την 

πρωτότυπη κατασκευή και δοκιμή ενός ηλεκτρονικού 

κυκλώματος. Το εσωτερικό αποτελείται από σειρές 

μικροσκοπικών μεταλλικών κλιπ για να συγκρατούν τα καλώδια 

που πρόκειται να συνδεθούν. 

Τα περισσότερα breadboard έχουν σειρές αριθμών, γραμμάτων 

και σύμβολα συν και πλην γραμμένα πάνω στις σειρές. Ο 

σκοπός των ετικετών είναι να σας βοηθήσουν να εντοπίσετε 

συγκεκριμένες οπές στο breadboard, ώστε να μπορείτε να 

ακολουθείτε τις οδηγίες κατά την κατασκευή ενός κυκλώματος. 

Οι μακριές λωρίδες στις 2 πλευρές του breadboard συνήθως 

σημειώνονται με κόκκινο και μπλε ή κόκκινο και μαύρο και με τα 

σημάδια συν (+) και πλην (-) αντίστοιχα. Αυτές οι σειρές 

ονομάζονται ράγες τροφοδοσίας και χρησιμοποιούνται συνήθως 

για την παροχή ηλεκτρικής ενέργειας στο κύκλωμα όταν 

συνδέονται σε τροφοδοτικό (μπαταρία ή εξωτερική παροχή). 
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Η θετική ράγα σημειώνεται με κόκκινο χρώμα, έχει το σύμβολο 

συν (+) και παρέχει την ισχύ.  

Η αρνητική ράγα σημειώνεται με μπλε ή μαύρο, έχει το σύμβολο 

πλήν (-) και παρέχει τη γείωση. 

Πλεονεκτήματα της χρήσης ενός Breadboard: 

• Διευκολύνει τον γρήγορο έλεγχο απλών και 

πολύπλοκων κυκλωμάτων και την εύκολη επαλήθευση 

των κυκλωμάτων στο αρχικό τους στάδιο. 

• Εύκολη προσαρμογή. 

• Ευέλικτο. 

• Χωρίς διάνοιξη οπών. 

• Δεν απαιτείται συγκόλληση. 

• Εύκολος εντοπισμός σφαλμάτων κυκλωμάτων και 

προγραμμάτων. 
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2. Τι είναι η αντίσταση; 

 

Μια αντίσταση είναι ένα μικρό πακέτο αντίστασης. Η χρήση του 

σε ένα κύκλωμα μειώνει το ρεύμα κατά ένα ακριβές ποσό. Για να 

υπολογίσετε την αντοχή μιας αντίστασης υπάρχει ένα σχέδιο 

από χρωματιστές ταινίες. 

 

(Πηγή εικόνας: Future Owns) διαθέσιμη στη διεύθυνση 

https://www.tomshardware.com/how-to/resistor-color-codes 

Κοινοί κωδικοί χρωμάτων αντίστασης και οι χρήσεις τους: 

Τύπος 
αντίστασης 

4-Ζώνες 
Κωδικός 

χρώματος  

5- Ζώνες  

Κωδικός 

χρώματος 

Κοινή Χρήση 

220Ohm Κόκκινο-
Κόκκινο-Καφέ-

Χρυσό 

Κόκκινο-
Κόκκινο-Μαύρο-

Μαύρο-Χρυσό 

Προστασία από 
φως LED 

1K Ohm 

(1Kiloohm) 

Καφέ-Μαύρο-

Κόκκινο-Χρυσό 

Καφέ-Μαύρο-

Μαύρο-Καφέ-
Χρυσό 

Προστασία LED, 

Διαιρέτης τάσης 

Οι αντιστάσεις δεν έχουν πολικότητα, επομένως μπορούν να 

χρησιμοποιηθούν σε οποιονδήποτε προσανατολισμό σε ένα 
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κύκλωμα. Αλλά για να προσδιορίσουμε τις σωστές τιμές του 

κωδικού χρώματος της αντίστασης, πρέπει να κατανοήσουμε τις 

έγχρωμες ζώνες στην αντίσταση. 

Σε μια τυπική αντίσταση τεσσάρων ζωνών για δραστηριότητες 

χόμπι, υπάρχουν τρία ομαδοποιημένα χρώματα. Αυτά είναι τα 

πρώτα, τα δεύτερα σημαντικά στοιχεία και ο πολλαπλασιαστής. 

Η τελική ζώνη είναι η αντοχή της αντίστασης, με ένα περιθώριο 

σφάλματος αν θέλετε. Για την πλειοψηφία των χομπίστων, η 

αντοχή 5% (Χρυσή ζώνη) είναι πιο κοινή και αποτελεσματική. 

Αντίσταση 220 Ohm (4-Ζώνες) 

 

(Πηγή Εικόνας: Future) διαθέσιμο στη διεύθυνση 

https://www.tomshardware.com/how-to/resistor-color-codes 

1. Ο πρώτος σημαντικός αριθμός είναι κόκκινος και 

χρησιμοποιώντας τον αποκωδικοποιητή μπορούμε να 

δούμε ότι το κόκκινο έχει τιμή 2. 

2. Ο δεύτερος σημαντικός αριθμός είναι επίσης κόκκινος, 

οπότε μας δίνει 22. 

3. Ο πολλαπλασιαστής είναι καφέ και αυτός 

αποκωδικοποιείται στο 10. Αν πολλαπλασιάσουμε το 22 

με το 10, θα έχουμε 220. 

4. Η τελική ζώνη, η αντοχή, είναι χρυσή. Η χρυσή είναι 5%, 

που σημαίνει ότι μπορούμε να δεχτούμε αντίσταση με 

περιθώριο σφάλματος 5%. 

https://www.tomshardware.com/how-to/resistor-color-codes
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Για τους κατασκευαστές που απαιτούν μεγαλύτερη ακρίβεια, 

υπάρχουν επίσης αντιστάσεις με πέντε ζώνες που έχουν ένα 

τρίτο σημαντικό αριθμό. Η πρόσθετη εικόνα παρέχει σαφήνεια 

που μπορεί να είναι απαραίτητη σε κυκλώματα ευαίσθητα στην 

αντίσταση, όπως επιστημονικά όργανα και όργανα μηχανικής. 

Αντίσταση 1K Ohm (4-Ζώνες) 

 

(Πηγή Εικόνα: Tom’s Hardware) διαθέσιμη στη διεύθυνση 

https://www.tomshardware.com/how-to/resistor-color-codes 

1. Η 1η γραμμή είναι καφέ και χρησιμοποιώντας τον 

αποκωδικοποιητή, μπορούμε να δούμε ότι η τιμή είναι 1. 

2. Η 2η γραμμή είναι μαύρη, οπότε μας δίνει 10. 

3. Ο πολλαπλασιαστής είναι κόκκινος, και αυτός 

αποκωδικοποιείται στο 100. Αν πολλαπλασιάσουμε το 

10 με το 100 θα έχουμε 1000. 

4. Η τελική γραμμή, η αντοχή, είναι χρυσή. Το χρυσό είναι 

5%, που σημαίνει ότι μπορούμε να δεχτούμε αντίσταση 

με περιθώριο σφάλματος 5%. 

 

https://www.tomshardware.com/how-to/resistor-color-codes
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3. Τι είναι ένας πυκνωτής; 

 

Ένας πυκνωτής είναι μια συσκευή που αποθηκεύει ηλεκτρική 

ενέργεια σε ένα ηλεκτρικό πεδίο. Είναι ένα παθητικό ηλεκτρονικό 

εξάρτημα με δύο τερματικά. Αποτελείται από δύο ηλεκτρικούς 

αγωγούς που χωρίζονται με απόσταση. Ο χώρος μεταξύ των 

αγωγών μπορεί να συμπληρωθεί με κενό ή με ένα μονωτικό 

υλικό γνωστό ως διηλεκτρικό. (Βικιπαίδεια) 

Ο πυκνωτής 100uF είναι ένας πυκνωτής ηλεκτρολυτικής 

αποσύνδεσης. Αυτοί οι πυκνωτές είναι εξαιρετικοί καταστολείς 

μεταβατικών υπερτάσεων και η χρήση ενός πυκνωτή μεταξύ της 

ισχύος και της γείωσης του κυκλώματος εξασφαλίζει την ομαλή 

παροχή ισχύος. 

4. Τι είναι δίοδος; 

 

Μια δίοδος είναι ένα ηλεκτρονικό εξάρτημα δύο ακροδεκτών που 

μεταφέρει ρεύμα κυρίως προς μία κατεύθυνση (ασύμμετρη 

αγωγιμότητα), έχει χαμηλή (ιδανικά μηδενική) αντίσταση στη μία 

κατεύθυνση και υψηλή (ιδανικά άπειρη) αντίσταση στην άλλη. 

Η πιο κοινή λειτουργία μιας διόδου είναι να επιτρέπει σε ένα 

ηλεκτρικό ρεύμα να διέρχεται προς μία κατεύθυνση (που 

ονομάζεται κατεύθυνση προς τα εμπρός της διόδου), ενώ το 

εμποδίζει προς την αντίθετη κατεύθυνση (την αντίστροφη 

κατεύθυνση). Ως εκ τούτου, η δίοδος μπορεί να θεωρηθεί ως μια 

ηλεκτρονική έκδοση μιας βαλβίδας ασφαλείας. Αυτή η 

συμπεριφορά μονής κατεύθυνσης ονομάζεται αποκατάσταση και 
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χρησιμοποιείται για τη μετατροπή του εναλλασσόμενου 

ρεύματος (ac) σε συνεχές ρεύμα (dc). Ως διορθωτικά, οι δίοδοι 

μπορούν να χρησιμοποιηθούν για εργασίες όπως η εξαγωγή της 

διαμόρφωσης των ραδιοσημάτων σε ραδιοφωνικούς δέκτες. 

(Wikipedia https://en.wikipedia.org/wiki/Diode) 

5. Τι είναι ένα καλώδιο jumper (γεφύρωσης/ 
βραχυκυκλώματος) ; 

 

 

Τα καλώδια Jumper (γεφύρωσης/ βραχυκυκλώματος) είναι απλά 

καλώδια που έχουν ακροδέκτες σύνδεσης σε κάθε άκρο, 

επιτρέποντάς τους να χρησιμοποιούνται για τη σύνδεση δύο 

σημείων μεταξύ τους χωρίς συγκόλληση. Τα καλώδια αυτά 

χρησιμοποιούνται συνήθως με breadboards και άλλα εργαλεία 

δημιουργίας πρωτοτύπων ηλεκτρονικών προκειμένου να είναι 

εύκολη η αλλαγή ενός κυκλώματος όπως απαιτείται. Η 

χρωματική διακύμανση των καλωδίων μπορεί να χρησιμοποιηθεί 

ως πλεονέκτημα για τη διαφοροποίηση μεταξύ των τύπων 

συνδέσεων, όπως γείωση ή τροφοδοσία. 

Τα καλώδια αυτά συνήθως διατίθενται σε τρεις εκδόσεις: 

αρσενικό σε αρσενικό, αρσενικό σε θηλυκό και θηλυκό σε 

θηλυκό. Η διαφορά μεταξύ του καθενός είναι στο τελικό σημείο 

του καλωδίου. Τα αρσενικά άκρα έχουν μια καρφίτσα που 

προεξέχει και μπορεί να συνδέσει σε αντικείμενα, ενώ τα θηλυκά 

https://en.wikipedia.org/wiki/Diode)
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άκρα δεν έχουν και χρησιμοποιούνται για να συνδέσουν 

αντικείμενα. Τα καλώδια από αρσενικό σε αρσενικό είναι τα πιο 

κοινά. Όταν συνδέετε δύο θύρες σε ένα breadboard, απαιτείται 

κυρίως καλώδιο αρσενικό σε αρσενικό. 

(https://blog.sparkfuneducation.com/what-is-jumper-wire)  

https://blog.sparkfuneducation.com/what-is-jumper-wire
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Προετοιμασία Πειραμάτων 

1. Διαβάστε πριν ξεκινήσετε 

ΣΗΜΕΙΩΣΗ: Δεδομένου ότι τα εμπλεκόμενα πειράματα είναι όλα 

πειράματα κυκλωμάτων, η λανθασμένη σύνδεση ή ένα 

βραχυκύκλωμα μπορεί να προκαλέσει βλάβη στην πλακέτα RPi 

Pico. Παρακαλούμε, ελέγχετε πάντα ξανά το κύκλωμα πριν 

συνδέσετε το τροφοδοτικό. 

2. Ο Μικροελεγκτής Raspberry Pi Pico 

Αυτό είναι ένα Raspberry Pi Pico: 

 

Συνδέστε το καλώδιο micro-USB στη θύρα στην αριστερή 

πλευρά της πλακέτας. 
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3. Εγκαταστήστε το Thonny IDE 

Επισκεφτείτε τη διεύθυνση https://thonny.org και επιλέξτε το 

κατάλληλο λειτουργικό σύστημα. Ακολουθήστε τις οδηγίες για να 

ολοκληρώσετε την εγκατάσταση. 

 

Σε αυτό το εγχειρίδιο, όλα τα πειράματα προγραμματίζονται σε 

Windows 10, χρησιμοποιώντας ένα Raspberry Pi Pico και το 

κατάλληλο υλικολογισμικό (firmware). 

Αφού ολοκληρωθεί η εγκατάσταση, ανοίξτε το Thonny από τον 

υπολογιστή σας. 
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4. Εγκατάσταση υλικολογισμικού (firmware) 

Το Raspberry Pi Pico μπορεί να προγραμματιστεί 

χρησιμοποιώντας μια παραλλαγή της Python, που ονομάζεται 

MicroPython. Για να χρησιμοποιήσετε τη MicroPython στο Pico, 

πρέπει πρώτα να εγκαταστήσετε το λογισμικό της. 

Βήμα 1: Βρείτε το κουμπί BOOTSEL στο Raspberry Pi Pico σας. 

 

Βήμα 2: Πατήστε το κουμπί BOOTSEL και κρατήστε το ενώ 

συνδέετε το άλλο άκρο του καλωδίου micro-USB στον 

υπολογιστή σας. 

Βήμα 3: Στην κάτω δεξιά γωνία του Thonny θα δείτε την έκδοση 

της Python που χρησιμοποιείτε αυτήν τη στιγμή. 

 

Κάντε κλικ στην έκδοση Python και επιλέξτε το MicroPython 

(Raspberry Pi Pico) 

 

Εάν δεν βλέπετε αυτήν την επιλογή, βεβαιωθείτε ότι το καλώδιο 

είναι σωστά συνδεδεμένο στο Pico ή/και στον υπολογιστή σας. 
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Βήμα 4: Θα εμφανιστεί ένα παράθυρο διαλόγου, το οποίο σας 

ζητά να εγκαταστήσετε την πιο πρόσφατη έκδοση 

υλικολογισμικού στο Pico σας. Κάντε κλικ στο κουμπί 

Εγκατάσταση για να αντιγράψετε το υλικολογισμικό στο Pico 

σας. 

 

Βήμα 5: Περιμένετε να ολοκληρωθεί η εγκατάσταση και κάντε 

κλικ στο Κλείσιμο. 

 

Δεν χρειάζεται να επαναλαμβάνετε τη διαδικασία κάθε φορά που 

συνδέετε το Raspberry Pi Pico στον υπολογιστή σας, οπότε την 

επόμενη φορά, απλώς συνδέστε το και είστε έτοιμοι. 
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5. Εισαγωγή στον Προγραμματισμό με MicroPython 

Τώρα θα χρησιμοποιήσετε το Thonny IDE για να εκτελέσετε έναν 

απλό κώδικα Python για να εξοικειωθείτε με το Thonny Shell και 

το MicroPython. 

Πρώτα βεβαιωθείτε ότι το Raspberry Pi Pico είναι συνδεδεμένο 

στον υπολογιστή σας και ότι έχετε επιλέξει τον διερμηνέα 

MicroPython όπως υποδεικνύεται στην προηγούμενη ενότητα. 

Ο πίνακας Shell στο κάτω μέρος του επεξεργαστή Thonny θα 

πρέπει να μοιάζει με αυτό: 

 

Ο Thonny είναι έτοιμος να επικοινωνήσει με το Pico σας 

χρησιμοποιώντας το πλαίσιο REPL (read-eval-print loop), το 

οποίο σας επιτρέπει να γράψετε κώδικα απευθείας στο Shell και 

να λάβετε έξοδο. 

Πληκτρολογήστε την ακόλουθη εντολή: 

print(“Hello!”) 

Στη συνέχεια, πατήστε το πλήκτρο Enter και δείτε το ακόλουθο 

αποτέλεσμα:

 

Η MicroPython σάς επιτρέπει να προσθέσετε ενότητες ειδικά για 

το υλικό, όπως machine, που μπορείτε να χρησιμοποιήσετε για 

να προγραμματίσετε το Pico σας. Στο παρακάτω παράδειγμα, θα 

χρησιμοποιήσετε τη μονάδα machine για να ενεργοποιήσετε το 

ενσωματωμένο LED του Pico. 
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Γράψτε τον παρακάτω κώδικα στο Thonny Shell: 
from machine import Pin 

led = Pin(25, Pin.OUT) 

led.value(1) 

 

Πατήστε το πλήκτρο Enter και αμέσως θα ανάψει το 

ενσωματωμένο LED του Pico. 

 

Για να απενεργοποιήσετε το LED γράψτε τον ακόλουθο κώδικα: 

led.value(0) 

  

Για το υπόλοιπο αυτής της ενότητας, θα γράψετε το πρώτο σας 

«πραγματικό» πρόγραμμα που θα κάνει το ενσωματωμένο LED 

να αναβοσβήνει κάθε φορά που εκτελείτε το πρόγραμμά σας. 

Το Thonny Shell είναι χρήσιμο για να δοκιμάσετε γρήγορες 

εντολές και να βεβαιωθείτε ότι όλα λειτουργούν σωστά. Ωστόσο, 

τα μεγαλύτερα προγράμματα θα πρέπει να αποθηκεύονται σε 

ένα αρχείο .py. Χρησιμοποιώντας το Thonny, μπορείτε να 
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αποθηκεύσετε προγράμματα απευθείας στο Raspberry Pi Pico 

και στη συνέχεια να τα εκτελέσετε. 

Ανοίξτε το Thonny Python και στο κύριο παράθυρο του 

επεξεργαστή γράψτε τον ακόλουθο κώδικα: 

 
from machine import Pin 

led = Pin(25, Pin.OUT) 

led.toggle() 

Τώρα, αποθηκεύστε το πρόγραμμά σας κάνοντας κλικ στο 

εικονίδιο Αποθήκευση στην επάνω αριστερή πλευρά ή πατώντας 

Ctrl+S στο πληκτρολόγιό σας. 

 

Το Thonny θα σας ρωτήσει πού θέλετε να αποθηκευτεί το 

πρόγραμμά σας. Επιλέξτε το Raspberry Pi Pico. Αποθηκεύστε 

το αρχείο ως blink.py και κάντε κλικ στο OK. Πρέπει πάντα να 



 
2021-1-FR01-KA220-SCH-000031617 

 

 

 
 

21 

προσθέτετε την επέκταση .py έτσι ώστε να αναγνωρίζει το αρχείο 

ως αρχείο Python. 

 

Τώρα, κάθε φορά που κάνετε κλικ στο εικονίδιο Αναπαραγωγή, 

θα πρέπει να βλέπετε το ενσωματωμένο LED να ανάβει και να 

σβήνει. 

Πηγαίνοντας τον κώδικά σας ένα βήμα παραπέρα, μπορείτε να 

κάνετε το ενσωματωμένο LED να αναβοσβήνει με συγκεκριμένο 

ρυθμό. 

Γράψτε τον παρακάτω κώδικα και αποθηκεύστε το πρόγραμμά 

σας χρησιμοποιώντας το ίδιο όνομα όπως παραπάνω. 
from machine import Pin 

from time import sleep 

led = Pin(25, Pin.OUT) 

while True: 

 led.toggle() 

 sleep(1) 

Τώρα όταν εκτελείτε το πρόγραμμα, το ενσωματωμένο LED θα 

αναβοσβήνει κάθε 1 δευτερόλεπτο μέχρι να σταματήσουμε το 

πρόγραμμα. Για να σταματήσετε το πρόγραμμα μπορείτε να 

κάνετε κλικ στο εικονίδιο STOP ή να πατήσετε Ctrl+C στο 

πληκτρολόγιό σας. 

Σε μελλοντικά πειράματα, θα μάθουμε πώς να προσθέτουμε και 

να ελέγχουμε άλλα ηλεκτρονικά και αισθητήρες και να 

δημιουργούμε προγράμματα που μπορούν να επικοινωνούν 

μεταξύ τους. 
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Συναρμολόγηση κιτ 

Το κιτ SCRAPY περιλαμβάνει τα ακόλουθα εξαρτήματα: 

• 1x 3D εκτυπωμένη βάση 

• 1 x τεμάχιο πλεξιγκλάς 

• 1 x Raspberry Pi Pico 

• 1 x πλακέτα διακοπής GPIO 

• 1 x Breadboard (830 τμχ) 

• 10 x Πλαστικές βίδες 

• 6 x 12mm πλαστικές κολόνες 

• 4 x 6mm πλαστικές κολόνες 

• 6 x Πλαστικά nuts 

 

Η διαδικασία συναρμολόγησης είναι απλή και μπορεί να 

ολοκληρωθεί σε 6 βήματα: 
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Βήμα 1: Τοποθετήστε τις πλαστικές κολόνες 6 x 12 mm με τα 

πλαστικά παξιμάδια 6 x στο κομμάτι plexiglass. 

 

 

Βήμα 2: Στο τρισδιάστατο εκτυπωμένο κομμάτι, τοποθετήστε 4 x 

6 mm πλαστικές κολόνες στην ενότητα "GPIO Breakout Board". 
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Βήμα 3: Τοποθετήστε την πλακέτα GPIO Breakout στις 4 

κολόνες χρησιμοποιώντας 4 πλαστικές βίδες. 

 

 

Βήμα 4: Τοποθετήστε το 3D εκτυπωμένο αντικείμενο με το 

αντικείμενο plexiglass χρησιμοποιώντας 6 πλαστικές βίδες στις 6 

πλαστικές κολόνες που τοποθετήσατε στο Βήμα 1. 
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Βήμα 5: Αφαιρέστε την προστατευτική ταινία κάτω από το 

breadboard των 830 τμχ και τοποθετήστε την στο τμήμα 

"Breadboard" του κιτ. Βεβαιωθείτε ότι η θετική (+) πλευρά του 

breadboard είναι στην κορυφή, όπως δείχνει η παρακάτω εικόνα. 

 

Βήμα 6: Τοποθετήστε το Raspberry Pi Pico πάνω από το GPIO 

Breakout Board και πιέστε το επάνω του μέχρι να εισαχθούν 

σωστά όλες οι ακίδες GPIO. Βεβαιωθείτε ότι η υποδοχή micro-

USB βρίσκεται στην επάνω πλευρά, όπως δείχνει η εικόνα. 
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Βασικά πειράματα   

0. «Hello SCRAPY people!» 

Σε αυτό το βασικό πείραμα, θα μάθουμε πώς να εμφανίζουμε ένα 

απλό μήνυμα στο Thonny χρησιμοποιώντας την γλώσσα 

προγραμματισμού Python. 

Η λειτουργία print()  

1. Μεταβείτε στον επεξεργαστή Thonny, γράψτε τον 

παρακάτω κώδικα και πατήστε το εικονίδιο 

αναπαραγωγής. Το πρόγραμμα Thonny θα σας ζητήσει 

να αποθηκεύσετε πρώτα το πρόγραμμά σας. 

Αποθηκεύστε το με το όνομα hello.py. 

 

2. Ελέγξτε το παράθυρο shell. 

 

3. Καλή δουλειά! Μόλις δημιουργήσατε το πρώτο σας 

πρόγραμμα Python.  
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Η λειτουργία print() είναι μια ενσωματωμένη συνάρτηση Python 

που μας επιτρέπει να εκτυπώνουμε κείμενο στο shell. Μπορεί 

επίσης να πάρει παραμέτρους. Δημιουργήστε ένα νέο 

πρόγραμμα και αντιγράψτε τον παρακάτω κώδικα, μετά πατήστε 

play και δείτε πώς εμφανίζεται το κείμενο στο shell.

 

Όπως μπορείτε να δείτε από το παράθυρο shell, κάθε λειτουργία 

print() εμφανίζει το κείμενο σε ξεχωριστή γραμμή. Ωστόσο, εάν 

χρησιμοποιείτε το "\n" (χαρακτήρας νέας γραμμής), μπορείτε να 

αλλάξετε γραμμή στην ίδια πρόταση . 

 

Άσκηση 

Χρησιμοποιήστε τη λειτουργία print() για να εμφανίσετε σε 3 

ξεχωριστές γραμμές "Goodbye SCRAPY people!" 

χρησιμοποιώντας μόνο μία δήλωση εκτύπωσης.  
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1. Ελέγξτε ένα LED 

Περιγραφή 

Σε αυτό το πείραμα θα μάθετε πώς να συνδέετε και να ελέγχετε 

ένα φως LED. Ανοίξτε το Thonny Python και μετά μεταβείτε στο 

File → Save as…, (Αρχείο → Αποθήκευση ως) επιλέξτε 

Raspberry Pi Pico και αποθηκεύστε το αρχείο σας με το όνομα 

led.py. Τότε είναι ώρα να συνδέσετε τα ηλεκτρονικά και να 

γράψετε το πρόγραμμά σας. Ακολουθήστε τις παρακάτω 

οδηγίες. 

Απαιτούμενο υλικό 

• 1 x Raspberry Pi Pico • 2 x καλώδιο jumper αρσενικό σε 
αρσενικό 

• 1 x breadboard πλήρους 
μεγέθους 

• 1 x LED (οποιοδήποτε χρώμα) 

• 1 x Micro-USB καλώδιο  • 1 x αντίσταση  220 Ohm  

 

Διάγραμμα συνδεσμολογίας 

 

– συνδέστε το μεγαλύτερο άκρο (+) της λυχνίας LED σε 

αντίσταση 220 Ohm 

– συνδέστε την αντίσταση στο GPIO5 (κόκκινο καλώδιο) 

– συνδέστε το μικρότερο άκρο (-) του LED σε μια ακίδα GND 
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Κώδικας 

Κώδικας MicroPython για το πείραμα: 

 

Παράδειγμα 

Εικόνα της εμφάνισης του κυκλώματος χρησιμοποιώντας το 

παρεχόμενο υλικό: 
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2. Πιέστε το κουμπί 

Περιγραφή 

Σε αυτό το πείραμα θα μάθετε πώς να συνδέετε και να ελέγχετε 

ένα κουμπί. Ανοίξτε το Thonny Python και μετά μεταβείτε στο File 

→ Save as…, (Αρχείο → Αποθήκευση ως), επιλέξτε Raspberry 

Pi Pico και αποθηκεύστε το αρχείο σας κάτω από το όνομα 

button.py. Τότε είναι ώρα να συνδέσετε τα ηλεκτρονικά και να 

γράψετε το πρόγραμμά σας. Ακολουθήστε τις παρακάτω 

οδηγίες. 

Απαιτούμενο υλικό 

• 1 x Raspberry Pi Pico • 1 x κιτ breadboard Pico 

• 1 x breadboard πλήρους 
μεγέθους 

• 3 x καλώδια jumper αρσενικό σε 
αρσενικό 

• 1 x καλώδιο Micro-USB • 1 x Αντίσταση 220 Ohm 

• 1 x κουμπί  • 1 x Καπάκι κουμπιού 

Διάγραμμα συνδεσμολογίας  

 

– συνδέστε την πάνω αριστερή πλευρά του κουμπιού στην ακίδα 3v3 
(κόκκινο καλώδιο) 

– συνδέστε την κάτω δεξιά πλευρά του κουμπιού στο GPIO5 (κίτρινο 
καλώδιο) 

– συνδέστε έναν πείρο GND στη γραμμή (-) (μαύρο καλώδιο) 

– συνδέστε την αντίσταση 220 Ohm στη γραμμή (-) και στην κάτω δεξιά 
πλευρά του κουμπιού 



 
2021-1-FR01-KA220-SCH-000031617 

 

 

 
 

31 

Κώδικας 

Κώδικας MicroPython για το πείραμα: 

 

Παράδειγμα 

Εικόνα της εμφάνισης του κυκλώματος χρησιμοποιώντας το 

παρεχόμενο υλικό 
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3. Buzzer 

Περιγραφή 

Σε αυτό το πείραμα θα μάθετε πώς να συνδέετε και να ελέγχετε 

έναν βομβητή (Buzzer). Ανοίξτε το Thonny Python και μετά 

μεταβείτε στο File → Save as…, (Αρχείο → Αποθήκευση ως), 

επιλέξτε Raspberry Pi Pico και αποθηκεύστε το αρχείο σας με το 

όνομα buzzer.py. Έπειτα είναι ώρα να συνδέσετε τα 

ηλεκτρονικά και να γράψετε το πρόγραμμά σας. Ακολουθήστε τις 

παρακάτω οδηγίες. 

 

Απαιτούμενο υλικό 

• 1 x Raspberry Pi Pico • 1 x κιτ breadboard Pico 

• 1 x breadboard πλήρους 
μεγέθους 

• 2 x καλώδια jumper αρσενικό σε 
αρσενικό 

• 1 x καλώδιο Micro-USB • 1 x Βομβητής 

 

Διάγραμμα συνδεσμολογίας 

 

– συνδέστε το μεγαλύτερο άκρο (+) του βομβητή στην ακίδα 

GPIO5 

– συνδέστε το μικρότερο άκρο (-) του βομβητή σε μια ακίδα GND 
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Κώδικας 

Κώδικας MicroPython για το πείραμα: 

 

Παράδειγμα 

Εικόνα της εμφάνισης του κυκλώματος χρησιμοποιώντας το 

παρεχόμενο υλικό: 
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4. Ποτενσιόμετρο 

Περιγραφή 

Σε αυτό το πείραμα θα μάθετε πώς να συνδέετε και να ελέγχετε 

το ποτενσιόμετρο. Ανοίξτε το Thonny Python και μετά μεταβείτε 

στο File → Save as…, (Αρχείο → Αποθήκευση ως), επιλέξτε 

Raspberry Pi Pico και αποθηκεύστε το αρχείο σας με το όνομα 

pot.py. Τότε είναι ώρα να συνδέσετε τα ηλεκτρονικά και να 

γράψετε το πρόγραμμά σας. Ακολουθήστε τις παρακάτω 

οδηγίες. 

Απαιτούμενο υλικό 

• 1 x Raspberry Pi Pico • 1 x κιτ breadboard Pico 

• 1 x breadboard πλήρους 
μεγέθους 

• 3 x καλώδια jumper αρσενικό 
σε αρσενικό 

• 1 x καλώδιο Micro-USB • 1 x Ποτενσιόμετρο 

Διάγραμμα συνδεσμολογίας 

 

– Το μαύρο καλώδιο πρέπει να συνδεθεί στην ακίδα GND (Pin 
3). 

– Το κίτρινο καλώδιο πρέπει να συνδεθεί στην ακίδα GPIO5 

–Το κόκκινο καλώδιο να συνδεθεί σε ακίδα τροφοδοσίας 3V3 

– Γυρίστε το ποτενσιόμετρο προς τα αριστερά ώστε να είναι 
απενεργοποιημένο 
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Κώδικας 

Κώδικας MicroPython για το πείραμα:

 

Παράδειγμα 

Εικόνα της εμφάνισης του κυκλώματος χρησιμοποιώντας το 

παρεχόμενο υλικό: 
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5. RGB LED 

Περιγραφή 

Σε αυτό το πείραμα θα μάθετε πώς να συνδέετε και να ελέγχετε 

μια λυχνία μονάδας LED RGB. Ανοίξτε το Thonny Python και 

μετά μεταβείτε στο File → Save as…, (Αρχείο → Αποθήκευση 

ως), επιλέξτε Raspberry Pi Pico και αποθηκεύστε το αρχείο σας 

με το όνομα rgb.py. Τότε είναι ώρα να συνδέσετε τα 

ηλεκτρονικά και να γράψετε το πρόγραμμά σας. Ακολουθήστε τις 

παρακάτω οδηγίες. 

Απαιτούμενο υλικό 

• 1 x Raspberry Pi Pico • 1 x κιτ breadboard Pico 

• 1 x breadboard πλήρους 
μεγέθους 

• 4 x καλώδια jumper αρσενικό 
σε αρσενικό 

• 1 x καλώδιο Micro-USB • 1 x RGB μονάδα LED 

Διάγραμμα συνδεσμολογίας

 

– Το κόκκινο καλώδιο πρέπει να συνδεθεί στο GPIO2 

– Το πράσινο καλώδιο πρέπει να είναι συνδεδεμένο στο GPIO3 

– Το μπλε καλώδιο πρέπει να συνδεθεί στο GPIO4 

– Δεν απαιτείται σύνδεση GND 
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Κώδικας 

Κώδικας MicroPython για το πείραμα:

 

Παράδειγμα 

Εικόνα της εμφάνισης του κυκλώματος χρησιμοποιώντας το 

παρεχόμενο υλικό: 

  



 
2021-1-FR01-KA220-SCH-000031617 

 

               

 
 

38 

Προχωρημένα πειράματα 

Πριν προχωρήσουμε σε αυτήν την ενότητα και στην επόμενη, 

πρέπει να κάνουμε μερικές τροποποιήσεις στο SCRAPY Κιτ. 

Αυτό περιλαμβάνει την προσθήκη μερικών επιπλέον 

εξαρτημάτων και τη συνδεσιμότητα τους. 

Απαιτούμενο υλικό 

• Πακέτο μπαταριών 1 x 6-AA • 1 x MB-102 μονάδα ισχύος 

• 4 x καλώδια jumper 
αρσενικού σε αρσενικό 

 

Ακολουθήστε το σχηματικό για να συνδέσετε τα νέα στοιχεία:
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Κύκλωμα 

 

– αυτή η ρύθμιση θα χρησιμοποιηθεί για τα υπόλοιπα πειράματα 

– Επάνω πλαϊνές συνδέσεις: VSYS 5V ((+) κόκκινο) και GND ((-

) μαύρο) 

– Συνδέσεις κάτω πλευράς: 3V3 ((+) κόκκινο) και GND ((-) 

μαύρο)  
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6. LDR Φωτοαντίσταση 

Περιγραφή 

Σε αυτό το πείραμα θα μάθετε πώς να συνδέετε και να ελέγχετε 

μια φωτοαντίσταση LDR. Ανοίξτε το Thonny Python και μετά 

μεταβείτε στο File → Save as…, (Αρχείο → Αποθήκευση ως), 

επιλέξτε Raspberry Pi Pico και αποθηκεύστε το αρχείο σας με το 

όνομα ldr.py. Τότε είναι ώρα να συνδέσετε τα ηλεκτρονικά και 

να γράψετε το πρόγραμμά σας. Ακολουθήστε τις παρακάτω 

οδηγίες. 

Απαιτούμενο υλικό 

• 1 x Raspberry Pi Pico • 1 x κιτ breadboard Pico 

• 1 x breadboard πλήρους 
μεγέθους 

• 3 x καλώδια jumper αρσενικό 
σε αρσενικό 

• 1 x καλώδιο Micro-USB • 1 x φωτοαντίσταση LDR 

• 1 x αντίσταση 220Ohm   

Διάγραμμα συνδεσμολογίας

 

– Η αριστερή πλευρά του LDR είναι συνδεδεμένη στη γραμμή 3V 
((+) κόκκινο) 

– Η δεξιά πλευρά του LDR συνδέεται με μια αντίσταση 220 Ohm 
και στην ακίδα GPIO26 ADC (κίτρινο καλώδιο) 

– η δεξιά πλευρά της αντίστασης συνδέεται με τη ράγα GND ((-) 
μαύρο) 
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Κώδικας 

Κώδικας MicroPython για το πείραμα:

 

Παράδειγμα 

Εικόνα της εμφάνισης του πειράματος χρησιμοποιώντας το 

παρεχόμενο υλικό: 
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7. Σερβοκινητήρας 

Περιγραφή 

Σε αυτό το πείραμα θα μάθετε πώς να συνδέετε και να ελέγχετε 

έναν σερβοκινητήρα. Ανοίξτε το Thonny Python και μετά 

μεταβείτε στο File → Save as…, (Αρχείο → Αποθήκευση ως), 

επιλέξτε Raspberry Pi Pico και αποθηκεύστε το αρχείο σας με το 

όνομα servo.py. Έπειτα μπορείτε να συνδέσετε τα ηλεκτρονικά 

και να γράψετε το πρόγραμμά σας. Ακολουθήστε τις παρακάτω 

οδηγίες 

Απαιτούμενο υλικό 

• 1 x Raspberry Pi Pico • 1 x κιτ breadboard Pico 

• 1 x breadboard πλήρους 
μεγέθους 

• 3 x καλώδια jumper αρσενικό 
σε αρσενικό 

•  1 x καλώδιο Micro-USB • 1 x SG-90 σερβοκινητήρα 

Διάγραμμα συνδεσμολογίας

 

– το κόκκινο καλώδιο συνδέεται στη γραμμή 5V (+) 

– Το μαύρο/καφέ καλώδιο συνδέεται στη γραμμή GND (-) 

– Το πορτοκαλί καλώδιο είναι συνδεδεμένο στην ακίδα ADC 

GPIO28 
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Κώδικας 

Κώδικας MicroPython για το πείραμα:

 

Παράδειγμα 

Εικόνα της εμφάνισης του πειράματος χρησιμοποιώντας το 

παρεχόμενο υλικό:
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8. Οθόνη OLED I2C SSD1306 

Περιγραφή 

Σε αυτό το πείραμα θα μάθετε πώς να συνδέετε και να ελέγχετε 

την οθόνη I2C ICC OLED. Ανοίξτε το Thonny Python και μετά 

μεταβείτε στο File → Save as…, (Αρχείο → Αποθήκευση ως), 

επιλέξτε Raspberry Pi Pico και αποθηκεύστε το αρχείο σας με το 

όνομα oled.py. Έπειτα μπορείτε να συνδέσετε τα ηλεκτρονικά 

και να γράψετε το πρόγραμμά σας. Ακολουθήστε τις παρακάτω 

οδηγίες. 

 

Απαιτούμενο υλικό 

• 1 x Raspberry Pi Pico • 1 x κιτ breadboard Pico 

• 1 x breadboard πλήρους 
μεγέθους 

• 4 x καλώδια jumper αρσενικό 
σε αρσενικό 

• 1 x καλώδιο Micro-USB • 1 x OLED I2C SSD1306 
οθόνη 

 

Διάγραμμα συνδεσμολογίας

 

– το κόκκινο καλώδιο συνδέεται στη γραμμή 3v3 (+) 

– Το μαύρο καλώδιο είναι συνδεδεμένο στη γραμμή GND (-) 
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– Το πορτοκαλί καλώδιο είναι συνδεδεμένο στην ακίδα GPIO17 

I2C0 SCL 

– Το μπλε καλώδιο συνδέεται στην ακίδα GPIO26 I2C0 SDA 

 

Κώδικας 

Πριν ξεκινήσουμε τον προγραμματισμό, την οθόνη OLED, 

πρέπει πρώτα να προσθέσουμε το πακέτο SSD1306 στο RPi 

Pico μας. Για να το κάνετε αυτό, ακολουθήστε τα παρακάτω 

βήματα: 

1. Ανοίξτε το Thonny και μεταβείτε στα Tools → Manage 

packages (Εργαλεία →  Διαχείριση πακέτων…) 
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2. Στο παράθυρο διαχείρισης πακέτων, πληκτρολογήστε 

SSD1306 και κάντε κλικ στην Αναζήτηση.

 

3. Μόλις ολοκληρωθεί η αναζήτηση, κάντε κλικ στο 

micropython-ssd1306.
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4. Στο επόμενο παράθυρο, κάντε κλικ στο Install.

 

5. Περιμένετε να εγκατασταθεί το πακέτο και μετά κάντε κλικ 

στο κλείσιμο. 

Τώρα, είμαστε έτοιμοι να προχωρήσουμε στον προγραμματισμό 

της οθόνης OLED. 



 
2021-1-FR01-KA220-SCH-000031617 

 

               

 
 

48 

Κώδικας MicroPython για το πείραμα:

 

Παράδειγμα 

Εικόνα της εμφάνισης του πειράματος χρησιμοποιώντας το 

παρεχόμενο υλικό:
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9. Μονάδα Joystick 

Περιγραφή 

Σε αυτό το πείραμα θα μάθετε πώς να συνδέετε και να ελέγχετε 
μια μονάδα joystick. Ανοίξτε το Thonny Python και μετά μεταβείτε 
στο File → Save as…, (Αρχείο → Αποθήκευση ως), επιλέξτε 
Raspberry Pi Pico και αποθηκεύστε το αρχείο σας με το όνομα 
joystick.py. Τότε είναι ώρα να συνδέσετε τα ηλεκτρονικά και 

να γράψετε το πρόγραμμά σας. Ακολουθήστε τις παρακάτω 
οδηγίες. 

Απαιτούμενο υλικό 

• 1 x Raspberry Pi Pico • 1 x κιτ breadboard Pico 

• 1 x breadboard πλήρους 
μεγέθους 

• 5 x καλώδια jumper αρσενικό σε 
αρσενικό 

• 1 x καλώδιο Micro-USB • 1 x μονάδα Joystick 

Διάγραμμα συνδεσμολογίας

 

– Το +5V (κόκκινο καλώδιο) συνδέεται στη γραμμή 5V (+) 
– Το GND (μαύρο καλώδιο) είναι συνδεδεμένο στη γραμμή GND 
(-) 
– Το VRx (μπλε καλώδιο) είναι συνδεδεμένο στην ακίδα GPIO27 
ADC1 
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– Το VRy (πορτοκαλί καλώδιο) είναι συνδεδεμένο στην ακίδα 
GPIO26 ADC0 
– Το καλώδιο SW (πράσινο) είναι συνδεδεμένο στην ακίδα 
GPIO22 
Κώδικας 

Κώδικας MicroPython για το πείραμα:

 

Παράδειγμα 

Εικόνα της εμφάνισης του πειράματος χρησιμοποιώντας το 

παρεχόμενο υλικό:
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Πειράματα με αισθητήρες 

10. Αισθητήρας σταγόνας βροχής 

Περιγραφή 

Σε αυτό το πείραμα θα μάθετε πώς να συνδέετε και να ελέγχετε 

τον αισθητήρα σταγόνας βροχής. Ανοίξτε το Thonny Python και 

μετά μεταβείτε στο File → Save as…, (Αρχείο → Αποθήκευση 

ως), επιλέξτε Raspberry Pi Pico και αποθηκεύστε το αρχείο σας 

με το όνομα raindrop.py. Έπειτα μπορείτε να συνδέσετε τα 

ηλεκτρονικά και να γράψετε το πρόγραμμά σας. Ακολουθήστε τις 

παρακάτω οδηγίες. 

Απαιτούμενο υλικό 

• 1 x Raspberry Pi Pico • 1 x κιτ breadboard Pico 

• 1 x breadboard πλήρους 
μεγέθους 

• 3 x καλώδια jumper αρσενικό 
σε αρσενικό 

• 1 x καλώδιο Micro-USB • 1 x Αισθητήρας σταγόνας 
βροχής 

Διάγραμμα συνδεσμολογίας
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– 3v3V (κόκκινο καλώδιο) συνδέεται με τη γραμμή 3v3V (+) 

– Το GND (μαύρο καλώδιο) είναι συνδεδεμένο στη γραμμή GND 

(-) 

– Το DO (πορτοκαλί καλώδιο) είναι συνδεδεμένο στην ακίδα 

GPIO17 

Κώδικας 

Κώδικας MicroPython για το πείραμα:
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Παράδειγμα 

Εικόνα της εμφάνισης του πειράματος χρησιμοποιώντας το 

παρεχόμενο υλικό:
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11. Αισθητήρας υπερήχων HC-SR04 

Περιγραφή 

Σε αυτό το πείραμα θα μάθετε πώς να συνδέετε και να ελέγχετε 

τον αισθητήρα υπερήχων HC-SR04. Ανοίξτε το Thonny Python 

και μετά μεταβείτε στο File → Save as…, (Αρχείο → Αποθήκευση 

ως), επιλέξτε Raspberry Pi Pico και αποθηκεύστε το αρχείο σας 

με το όνομα ultrasonic.py. Έπειτα μπορείτε να συνδέσετε τα 

ηλεκτρονικά και να γράψετε το πρόγραμμά σας. Ακολουθήστε τις 

παρακάτω οδηγίες. 

Απαιτούμενο υλικό 

• 1 x Raspberry Pi Pico • 1 x κιτ breadboard Pico 

• 1 x breadboard πλήρους 
μεγέθους 

• 3 x καλώδια jumper αρσενικό 
σε αρσενικό 

• 1 x καλώδιο Micro-USB • 1 x HC-SR04 Αισθητήρας 
υπερήχων 

Διάγραμμα συνδεσμολογίας

 

- Το VCC (κόκκινο καλώδιο) είναι συνδεδεμένο στη γραμμή 5V 
(+) 

- GND (μαύρο καλώδιο) συνδέεται στη γραμμή GND (-) 

- TRIG (πορτοκαλί καλώδιο) συνδέεται στην ακίδα GPIO2 

- ECHO (πράσινο καλώδιο) συνδέεται στην ακίδα GPIO3.  
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Κώδικας 

Για να χρησιμοποιήσουμε τον αισθητήρα υπερήχων HC-SR04 

μπορούμε να αναπτύξουμε το δικό μας πρόγραμμα ή να 

χρησιμοποιήσουμε μία από τις διαθέσιμες βιβλιοθήκες που 

υπάρχουν στο διαδίκτυο, π.χ. στο Github. Εάν επιλέξετε να 

κάνετε λήψη της βιβλιοθήκης hcsr04.py, θα πρέπει να την 

αποθηκεύσετε στο Pico σας με το ίδιο όνομα. 

Κώδικας MicroPython χρησιμοποιώντας μια υπάρχουσα 

βιβλιοθήκη: 

 

  

https://github.com/rsc1975/micropython-hcsr04/blob/master/hcsr04.py


 
2021-1-FR01-KA220-SCH-000031617 

 

               

 
 

56 

Κώδικας MicroPython χωρίς υπάρχουσα βιβλιοθήκη:

 

Παράδειγμα  

Εικόνα της εμφάνισης του πειράματος χρησιμοποιώντας το 

παρεχόμενο υλικό:
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12. Αισθητήρας κίνησης PIR 

Περιγραφή 

Σε αυτό το πείραμα θα μάθετε πώς να συνδέετε και να ελέγχετε 

τον αισθητήρα κίνησης PIR. Ανοίξτε το Thonny Python και μετά 

μεταβείτε στο File → Save as…, (Αρχείο → Αποθήκευση ως), 

επιλέξτε Raspberry Pi Pico και αποθηκεύστε το αρχείο σας με το 

όνομα motion.py. Έπειτα μπορείτε να συνδέσετε τα 

ηλεκτρονικά και να γράψετε το πρόγραμμά σας. Ακολουθήστε τις 

παρακάτω οδηγίες. 

Απαιτούμενο υλικό 

• 1 x Raspberry Pi Pico • 1 x κιτ breadboard Pico 

• 1 x breadboard πλήρους 
μεγέθους 

• 3 x καλώδια jumper από 
αρσενικό σε θηλυκό 

• 1 x καλώδιο Micro-USB • 1 x αισθητήρας κίνησης PIR 

Διάγραμμα συνδεσμολογίας

 

- Το VCC (κόκκινο καλώδιο) είναι συνδεδεμένο στη γραμμή 5V 
(+) 

- GND (μαύρο καλώδιο) συνδέεται στη γραμμή GND (-) 

- OUT (πορτοκαλί καλώδιο) συνδέεται στην ακίδα GPIO5  
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Κώδικας 

Κώδικας MicroPython για το πείραμα:

 

Παράδειγμα 

Εικόνα της εμφάνισης του πειράματος χρησιμοποιώντας το 

παρεχόμενο υλικό:
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13. Αισθητήρας DHT11 

Περιγραφή 

Σε αυτό το πείραμα θα μάθετε πώς να συνδέετε και να ελέγχετε 

τον αισθητήρα θερμοκρασίας και υγρασίας DHT11. Ανοίξτε το 

Thonny Python και μετά μεταβείτε στο File → Save as…, (Αρχείο 

→ Αποθήκευση ως), επιλέξτε Raspberry Pi Pico και 

αποθηκεύστε το αρχείο σας με το όνομα dht11.py. Έπειτα 

μπορείτε να συνδέσετε τα ηλεκτρονικά και να γράψετε το 

πρόγραμμά σας. Ακολουθήστε τις παρακάτω οδηγίες. 

Απαιτούμενο υλικό 

• 1 x Raspberry Pi Pico • 1 x κιτ breadboard Pico 

• 1 x breadboard πλήρους 
μεγέθους 

• 3 x καλώδια jumper αρσενικό σε 
αρσενικό 

• 1 x καλώδιο Micro-USB • 1 x αισθητήρας θερμοκρασίας 
DHT11 
 

Διάγραμμα συνδεσμολογίας

 

- Το VCC (κόκκινο καλώδιο) είναι συνδεδεμένο στη γραμμή 3v3 

(+) 

- Το GND (μαύρο καλώδιο) συνδέεται στη γραμμή GND (-) 

- Το S (πράσινο καλώδιο) συνδέεται στην ακίδα GPIO5.   
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Κώδικας 

Κώδικας MicroPython για το πείραμα:

 

Παράδειγμα 

Εικόνα της εμφάνισης του πειράματος χρησιμοποιώντας το 

παρεχόμενο υλικό:
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14. Αισθητήρας κραδασμών SW-420 

Περιγραφή 

Σε αυτό το πείραμα θα μάθετε πώς να συνδέετε και να ελέγχετε 

τον αισθητήρα κραδασμών SW-420. Ανοίξτε το Thonny Python 

και μετά μεταβείτε στο File → Save as…, (Αρχείο → Αποθήκευση 

ως), επιλέξτε Raspberry Pi Pico και αποθηκεύστε το αρχείο σας 

με το όνομα vibration.py. Τότε είναι ώρα να συνδέσετε τα 

ηλεκτρονικά και να γράψετε το πρόγραμμά σας. Ακολουθήστε τις 

παρακάτω οδηγίες. 

Απαιτούμενο υλικό 

• 1 x Raspberry Pi Pico • 1 x κιτ breadboard Pico 

• 1 x breadboard πλήρους 
μεγέθους 

• 3 x καλώδια jumper αρσενικό 
σε αρσενικό 

• 1 x καλώδιο Micro-USB • 1 x αισθητήρας κραδασμών 
SW-420 

Διάγραμμα συνδεσμολογίας

 

– Το VCC (κόκκινο καλώδιο) συνδέεται στη γραμμή 5V (+) 

– Το GND (μαύρο καλώδιο) είναι συνδεδεμένο στη γραμμή 
GND (-) 

– Το DO (πράσινο καλώδιο) είναι συνδεδεμένο στην ακίδα 
GPIO21  
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Κώδικας 

Κώδικας MicroPython για το πείραμα:

 

Παράδειγμα 

Εικόνα της εμφάνισης του πειράματος χρησιμοποιώντας το 

παρεχόμενο υλικό:
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15. Αισθητήρας φλόγας 

Περιγραφή 

Σε αυτό το πείραμα θα μάθετε πώς να συνδέετε και να ελέγχετε 

τον αισθητήρα φλόγας KY-026. Ανοίξτε το Thonny Python και 

μετά μεταβείτε στο File → Save as…, (Αρχείο → Αποθήκευση 

ως), επιλέξτε Raspberry Pi Pico και αποθηκεύστε το αρχείο σας 

με το όνομα flame.py. Τότε είναι ώρα να συνδέσετε τα 

ηλεκτρονικά και να γράψετε το πρόγραμμά σας. Ακολουθήστε τις 

παρακάτω οδηγίες. 

Απαιτούμενο υλικό 

• 1 x Raspberry Pi Pico • 1 x κιτ breadboard Pico 

• 1 x breadboard πλήρους 
μεγέθους 

• 3 x καλώδια jumper αρσενικό σε 
αρσενικό 

• 1 x καλώδιο Micro-USB • 1 x KY-026 αισθητήρας φλόγας  

Διάγραμμα συνδεσμολογίας

 

– Το VCC (κόκκινο καλώδιο) συνδέεται στη γραμμή 5V (+) 

– Το GND (μαύρο καλώδιο) είναι συνδεδεμένο στη γραμμή 
GND (-) 

– Το DO (πράσινο καλώδιο) είναι συνδεδεμένο στην ακίδα 
GPIO21  
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Κώδικας 

Κώδικας MicroPython για το πείραμα:

 

Παράδειγμα 

Εικόνα της εμφάνισης του πειράματος χρησιμοποιώντας το 

παρεχόμενο υλικό:
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16. Αισθητήρας ανίχνευσης ήχου 

Περιγραφή 

Σε αυτό το πείραμα θα μάθετε πώς να συνδέετε και να ελέγχετε 

τον αισθητήρα ανίχνευσης ήχου KY-037. Ανοίξτε το Thonny 

Python και μετά μεταβείτε στο File → Save as…, (Αρχείο → 
Αποθήκευση ως), επιλέξτε Raspberry Pi Pico και αποθηκεύστε 

το αρχείο σας με το όνομα sound.py. Τότε είναι ώρα να 

συνδέσετε τα ηλεκτρονικά και να γράψετε το πρόγραμμά σας. 

Ακολουθήστε τις παρακάτω οδηγίες. 

Απαιτούμενο υλικό 

• 1 x Raspberry Pi Pico • 1 x κιτ breadboard Pico 

• 1 x breadboard πλήρους 
μεγέθους 

• 3 x καλώδια jumper αρσενικό σε 
αρσενικό 

• 1 x καλώδιο Micro-USB • 1 x KY-037 αισθητήρας ήχου 

Διάγραμμα συνδεσμολογίας

 

– Το VCC (κόκκινο καλώδιο) συνδέεται στη γραμμή 5V (+) 

– Το GND (μαύρο καλώδιο) είναι συνδεδεμένο στη γραμμή 
GND (-) 

– Το DO/OUT (πράσινο καλώδιο) είναι συνδεδεμένο στην ακίδα 
GPIO21  
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Κώδικας 

Κώδικας MicroPython για το πείραμα:

 

Παράδειγμα 

Εικόνα της εμφάνισης του πειράματος χρησιμοποιώντας το 

παρεχόμενο υλικό:
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17. Αισθητήρας υγρασίας εδάφους 

Περιγραφή 

Σε αυτό το πείραμα θα μάθετε πώς να συνδέετε και να ελέγχετε 

τον αισθητήρα υγρασίας εδάφους. Ανοίξτε το Thonny Python και 

μετά μεταβείτε στο File → Save as…, (Αρχείο → Αποθήκευση 

ως), επιλέξτε Raspberry Pi Pico και αποθηκεύστε το αρχείο σας 

με το όνομα earth.py. Τότε είναι ώρα να συνδέσετε τα 

ηλεκτρονικά και να γράψετε το πρόγραμμά σας. Ακολουθήστε τις 

παρακάτω οδηγίες. 

Απαιτούμενο υλικό 

• 1 x Raspberry Pi Pico • 1 x κιτ breadboard Pico 

• 1 x breadboard πλήρους 
μεγέθους 

• 3 x καλώδια jumper αρσενικό 
σε αρσενικό 

• 1 x καλώδιο Micro-USB • 1 x KY-037 αισθητήρας ήχου 

Διάγραμμα συνδεσμολογίας

 

– Το VCC (κόκκινο καλώδιο) συνδέεται στη γραμμή 5V (+) 

– Το GND (μαύρο καλώδιο) είναι συνδεδεμένο στη γραμμή GND 

(-) 
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– Το DO/OUT (πράσινο καλώδιο) είναι συνδεδεμένο στην ακίδα 

GPIO21 

Κώδικας 

Κώδικας MicroPython για το πείραμα:

 

Παράδειγμα 

Εικόνα της εμφάνισης του πειράματος χρησιμοποιώντας το 

παρεχόμενο υλικό:
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18. Αισθητήρας IR  υπερύθρων  

Περιγραφή 

Σε αυτό το πείραμα θα μάθετε πώς να συνδέετε και να ελέγχετε 

τον αισθητήρα IR υπερύθρων. Ανοίξτε το Thonny Python και 

μετά μεταβείτε στο File → Save as…, (Αρχείο → Αποθήκευση 

ως), επιλέξτε Raspberry Pi Pico και αποθηκεύστε το αρχείο σας 

με το όνομα ir.py. Τότε είναι ώρα να συνδέσετε τα ηλεκτρονικά 

και να γράψετε το πρόγραμμά σας. Ακολουθήστε τις παρακάτω 

οδηγίες. 

Απαιτούμενο υλικό 

• 1 x Raspberry Pi Pico • 1 x κιτ breadboard Pico 

• 1 x breadboard πλήρους 
μεγέθους 

• 3 x καλώδια jumper αρσενικό 
σε αρσενικό 

• 1 x καλώδιο Micro-USB • 1 x Αισθητήρας IR 
υπερύθρων 

Διάγραμμα συνδεσμολογίας

 

– Το VCC (κόκκινο καλώδιο) συνδέεται στη γραμμή 5V (+) 

– Το GND (μαύρο καλώδιο) είναι συνδεδεμένο στη γραμμή GND 

(-) 
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– Το OUT (πράσινο καλώδιο) είναι συνδεδεμένο στην ακίδα 

GPIO21 

Κώδικας 

Κώδικας MicroPython για το πείραμα:

 

Παράδειγμα 

Εικόνα της εμφάνισης του πειράματος χρησιμοποιώντας το 

παρεχόμενο υλικό:

  



 
2021-1-FR01-KA220-SCH-000031617 

 

 

 
 

71 

ΠΑΡΑΡΤΗΜΑ: Συγκεντρωτικός Πίνακας 
MicroPython 

Ψηφιακή έξοδος 

Κλήση της κλάσης 
ακίδας «Pin class» 

from machine import Pin  

Ενεργοποίηση της 
ψηφιακής εξόδου του 
αντικειμένου.  

led = Pin(pin_value, Pin.OUT) pin_value από 0 έως 40 

Άνοιγμα της ψηφιακής 
εξόδου (έξοδος 3.3V) 

led.value(1) ON (Ανοιχτή)  

Κλείσιμο της ψηφιακής 
εξόδου (έξοδος 0V ) 

led.value(0) OFF (Κλειστή) 

 

Ψηφιακή είσοδος 

Κλήση της κλάσης 
ακίδας «Pin class» 

from machine import Pin  

Ενεργοποίηση της 
ψηφιακής εξόδου του 
αντικειμένου.  

button = Pin(pin_value, Pin.IN) pin_value από 0 μέχρι 40 

button = Pin(pin_value), 

Pin.IN, Pin.PULL_UP) 

Ενεργοποίηση αντίστασης 
PULL UP 

button = Pin(pin_value), 

Pin.IN, Pin.PULL_DOWN) 

Ενεργοποίηση αντίστασης 
PULL DOWN 

Ανάγνωση Εισόδου value = button.value(1) 

Η τιμή επιστροφής μπορεί 
να είναι 0 εάν η ακίδα είναι 

στα 0V ή 1 εάν η ακίδα 
είναι στα 3,3V 

 

Αναλογική Έξοδος (Διαμόρφωση πλάτους παλμού - PWM) 

Κλήση της κλάσης 
PWM  

from machine import PWM  

Ενεργοποίηση της 

αναλογικής εξόδου 

led = PWM(Pin(pin_value), 

frequency) 

pin_value από 0 μέχρι 40 

frequency σε HZ, από 0 

μέχρι 78125 

Ανάγνωση εισόδου led.duty(duty_cycle) 

duty_cycle από 0 έως 

1023 (έξοδος 0V σε έξοδο 
3.3V αντίστοιχα) 
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Αναλογική είσοδος 

Κλήση της κλάσης ADC  from machine import ADC  

Ενεργοποίηση της 
αναλογικής εισόδου 

pot = ADC(Pin(pin_value)) 
pin_value μπορεί να είναι 

GPIO26, GPIO27 και GPIO28 

Δήλωση σχετικά με το 
σε ποια τάση θα δώσει 
η είσοδος τη μέγιστη 
τιμή της (σε ESP32 
συνήθως είναι 3,3V) 

pot.atten(ADC.ATTN_11DB) 

ADC.ATTN_0DB: τάση πλήρους 
εύρους: 1,2 V 

ADC.ATTN_2_5DB: τάση πλήρους 
εύρους: 1,5 V 

ADC.ATTN_6DB: τάση πλήρους 
εύρους: 2,0 V 

ADC.ATTN_11DB: τάση πλήρους 
εύρους: 3,3 V 

Δήλωση του εύρους 
τιμών εισόδου 

(προεπιλογή 12 bit) 

pot.width(ADC.WIDTH_10BIT) 

ADC.WIDTH_9BIT: εύρος 0 έως 
511 

ADC.WIDTH_10BIT: εύρος 0 έως 
1023 

ADC.WIDTH_11BIT: εύρος 0 έως 
2047 

ADC.WIDTH_12BIT: εύρος 0 έως 
4095 

Ανάγνωση εισόδου value = pot.readl() 

value (η τιμή) είναι ένας ακέραιος 

αριθμός από το 0 έως το μέγιστο 
του εύρους που καθορίζεται από 
την εντολή ADC.WIDTH_#BIT (βλ. 
προηγούμενο) 

 

Η βιβλιοθήκη του χρόνου 

Κλήση της κλάσης  
καθυστέρησης/ 
αναμονής «sleep» 

from time import sleep  

Χρήση της κλάσης  
καθυστέρησης/ 
αναμονής «sleep» 

sleep(sec) 

sec είναι ο αριθμός των 

δευτερολέπτων για τα οποία θα 
καθυστερήσει το πρόγραμμα 

Κλήση της κλάσης  
χρόνου 

import time  

Χρήση της λειτουργίας 
χρόνου 

current_time = time() 

Η μεταβλητή current_time θα 

λάβει μια αριθμητική τιμή, ίση με τον 
αριθμό των δευτερολέπτων από 
την τελευταία επαναφορά στον 
πίνακα. 
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Δομή Εντολής «If» 

if <expr1>:  

     <statement1>  

elif <expr2>:  

     <statement2>  

elif <expr3>:  

     <statement3>  

     (...)  

else:  

     <statementn>  

<expr#>: η συνθήκη ελέγχου που πρέπει να επιστρέψει True (Σωστό) ή 
False (Λάθος)  

<statement#>: σύνολο εντολών που πρέπει να εκτελεστούν όταν 
ικανοποιείται η σχετική συνθήκη 

<expr#> (e.g. το σύνολο <statement2> εκτελείται όταν πληρείται η <expr2>) 

<statementn>: σύνολο εντολών που εκτελούνται όταν δεν πληρείται καμία 
από τις συνθήκες <expr#> 

 

Δομή της εντολής «While loop» 

while <expr>:  

   <statement(s)>  

<expr>: η συνθήκη ελέγχου που πρέπει να επιστρέψει True (Σωστό) ή 
False (Λάθος) 

<statement#>: σύνολο εντολών που θα εκτελούνται εφόσον πληρείται η 
συνθήκη <expr> 

 

Για τη δομή της εντολής «loop» 

for <var> in <iterable>: 

     <statement(s)> 

<iterable>: μια συλλογή στοιχείων, 
για παράδειγμα μια λίστα που 
περιέχει αριθμούς, αλφαριθμητικά 

κ.λπ. 

<var>: μια μεταβλητή στην οποία 
εκχωρείται η τιμή του επόμενου 
στοιχείου της συλλογής <iterable>. 

<stametement(s)>: ένα σύνολο 
εντολών που εκτελούνται σε κάθε 
επανάληψη 

for <var> in range(<start>, <end>, <step>): 

     <statement(s)> 

range(<start>, <end>, <step>): 
συνάρτηση που επιστρέφει μια 
ακολουθία αριθμών από <start> έως 

<end>-1, με διαφορά <step> μεταξύ 
δύο διαδοχικών αριθμών (οι 
παράμετροι <start> και <step> είναι 
προαιρετικές). 

<var>: μεταβλητή στην οποία 
αποδίδεται η τιμή του επόμενου 
στοιχείου της ακολουθίας που 
παράγεται από το εύρος. 

 

<statement(s)>: ένα σύνολο εντολών 

που εκτελούνται σε κάθε επανάληψη 
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Διάφορα 

DHT11 

import dht Εισαγωγή της βιβλιοθήκης DHT 

sensor = dht.DHT11(Pin(pin_number)) 

Ενεργοποίηση της μεταβλητής 
αισθητήρα με τον αντίστοιχο 
αριθμό ακίδας pin_number. 

sensor.measure() 
Ενημέρωση των μεταβλητών του 
αισθητήρα 

temp = sensor.temperature() 
Αποθήκευση τρέχουσας τιμής 
θερμοκρασίας 

hum = sensor.humidity() 
Αποθήκευση τρέχουσας τιμής 
υγρασίας 

ΟΘΟΝΗ 
OLED 

from machine import I2C Εισαγωγή της βιβλιοθήκης I2C 

import ssd1306 
Εισαγωγή της βιβλιοθήκης 
ssd1306 

i2c = I2C(-1, scl=Pin(1), sda=Pin(0)) 

Ενεργοποίηση της μεταβλητής 
i2c στις ακίδες SCL & SDA του 
Pico 

oled_width = 128 

oled_height = 64 

oled = ssd1306.SSD1306_I2C(oled_width, 

oled_height, i2c) 

Ενεργοποίηση της οθόνης 

oled.text('Hello, World 1!', 0, 0) 

oled.text('Hello, World 2!', 0, 10) 

oled.text('Hello, World 3!', 0, 20) 

Αποθήκευση μηνυμάτων στο 
buffer οθόνης 

oled.show() 

Εμφάνιση μηνυμάτων 
(απαραίτητο για την εμφάνιση 

των μηνυμάτων που είναι 
αποθηκευμένα στο buffer 
οθόνης) 

display.pixel(3, 4, 1) 

Θέστε το pixel που βρίσκεται στη 
θέση (x,y) της οθόνης, με x=3 & 
y=4, στην κατάσταση 1 (δηλ. 
εμφάνιση) 

 



 
w: scrapykit.eu 
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Η υποστήριξη της Ευρωπαϊκής Επιτροπής στην παραγωγή της παρούσας έκδοσης δεν συνιστά 

αποδοχή του περιεχομένου, το οποίο αντικατοπτρίζει αποκλειστικά τις απόψεις των συντακτών, 

και η Επιτροπή δεν μπορεί να αναλάβει την ευθύνη για οποιαδήποτε χρήση των πληροφοριών 

που περιέχονται σε αυτήν. 
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